Личный кабинет

Задание#T790

Ниже на пяти языках программирования записан рекурсивный алгоритм .

Бейсик

SUB F(n)
 IF n > 0 THEN
  F(n - 1)
  PRINT n
  F(n - 2)
 END IF
END SUB

Python

def F(n):
 if n > 0:
  F(n - 1)
  print(n)
  F(n - 2)

Алгоритмический язык

алг F(цел n)
нач
 если n > 0 то
  F(n - 1)
  вывод n
  F(n - 2)
 все
кон

Паскаль

procedure F(n: integer);
begin
 if n > 0 then
 begin
  F(n - 1);
  write(n);
  F(n - 2)
 end
end;

С++

void F(int n){
 if (n > 0){
  F(n - 1);
  std::cout << n;
  F(n - 2);
 }
}
Запишите подряд без пробелов и разделителей все числа, которые будут напечатаны на экране при выполнении вызова F(4). Числа должны быть записаны в том же порядке, в котором они выводятся на экран.
Показать ответ
Это задание взято из демовариантов ФИПИ 2018-2020
Это задание решали 10 тыс. раз. С ним справились 46% пользователей.

Рекомендованные задания

Для составления персональной подборки решено недостаточно заданий.
Повышайте свой балл на экзамене!
Решать задания
0 баллов сегодня
дней без пропуска

0
пн
0
вт
0
ср
0
чт
0
пт
0
сб
0
вс